# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"transactionid\\\":\\\"(?<transactionid>[^\\]++)"
test_str = "[Source: {\\\"commisionEvent\\\":{\\\"channel\\\":\\\"testString\\\",\\\"orderType\\\":\\\"testString\\\",\\\"eventSource\\\":\\\"testString\\\",\\\"eventCreationDate\\\":\\\"2018-02-10T00:30:21.298Z\\\",\\\"orderDate\\\":\\\"2018-02-10T00:30:21.298Z\\\",\\\"dealerCode\\\":\\\"testString\\\",\\\"ban\\\":\\\"123\\\",\\\"orderNo\\\":\\\"testString\\\",\\\"originalOrderNo\\\":\\\"testString\\\",\\\"customerName\\\":\\\"testString\\\",\\\"msisdn\\\":\\\"testString\\\",\\\"orderDetails\\\":[{\\\"sku\\\":\\\"testString\\\",\\\"imei\\\":\\\"testString\\\",\\\"msisdnLineLevel\\\":\\\"testString\\\",\\\"msrp\\\":\\\"1000.00\\\",\\\"customerPaidAmount\\\":\\\"1200.00\\\",\\\"sellingPrice\\\":\\\"1000.00\\\",\\\"jumpIndicator\\\":\\\"testString\\\",\\\"eipIndicator\\\":\\\"123\\\",\\\"eip1stPayment\\\":\\\"1100.00\\\",\\\"eipPlanId\\\":\\\"testString\\\",\\\"eipInitialAmount\\\":\\\"1000.00\\\",\\\"discount\\\":\\\"100.00\\\",\\\"transactionid\\\":\\\"testString\\\",\\\"shippedDate\\\":\\\"test\\\",\\\"priceoverrideamount\\\":\\\"1000.00\\\",\\\"priceOverrideCode\\\":\\\"testString\\\",\\\"overrideReason\\\":\\\"testString\\\",\\\"originalTransactionId\\\":\\\"testString\\\",\\\"lineType\\\":\\\"testString\\\",\\\"transactionType\\\":\\\"testString\\\"}]}}; line: 1, column: 676]"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.