re = /^(?:\S+\s){4}(?<fifthword>\S+)\s(?<sixthword>\S+)/m
str = '2023-01-22T08:50:53.642034+02:00 Forwarder-Kali sudo: meow : user NOT in sudoers ; TTY=pts/3 ; PWD=/root ; USER=root ; COMMAND=/usr/bin/cat /etc/passwd '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end