package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d+(?:\|\d+)?,)+\d+(?:\|\d+)?$`)
var str = `111|222,333,444
111
111,222|333,
111,222,333|
,111,222,333|444
|111,222|333,444
111,222|333,444
111|222,333,444`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}