# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\")((zombiePartyGirl)|(zombieArlene))((Feral)|(Radiated))?(?!\")"
test_str = ("<entitygroups>\n"
" <entitygroup name=\"ZombiesAll\">\n"
" zombieBoe\n"
" zombieJoe\n"
" zombieSteve\n"
" zombieTomClark\n"
" zombieMoe\n"
" zombieYo\n"
" zombieBusinessMan\n"
" zombieArlene\n"
" zombieDarlene\n"
" zombieMarlene\n"
" zombieSkateboarder\n"
" zombieBiker, .3\n"
" zombiePartyGirl, .3\n"
" zombieUtilityWorker, .3\n"
" zombieJanitor, .2\n"
" zombieNurse, .3\n"
" zombieSteveCrawler\n"
" zombieFatHawaiian, .3\n"
" </entitygroup>\n\n\n"
" <!-- *** POI_INDIVIDUAL_ENTITY_GROUPS -->\n"
" <entitygroup name=\"zombieArlene\">zombieArlene</entitygroup>\n"
" <entitygroup name=\"zombieArleneFeral\">zombieArleneFeral</entitygroup>\n"
" <entitygroup name=\"zombieArleneRadiated\">zombieArleneRadiated</entitygroup>\n"
" <entitygroup name=\"zombieMarlene\">zombieMarlene</entitygroup>\n"
" <entitygroup name=\"zombieMarleneFeral\">zombieMarleneFeral</entitygroup>\n"
" <entitygroup name=\"zombieMarleneRadiated\">zombieMarleneRadiated</entitygroup>\n"
" <entitygroup name=\"zombiePartyGirl\">zombiePartyGirl</entitygroup>\n"
" <entitygroup name=\"zombiePartyGirlFeral\">zombiePartyGirlFeral</entitygroup>\n"
" <entitygroup name=\"zombiePartyGirlRadiated\">zombiePartyGirlRadiated</entitygroup>\n\n"
"</entitygroups>")
subst = "zombieLab$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.