import re
regex = re.compile(r"(?<=ee|i)r\b", flags=re.MULTILINE)
test_str = ("beer\n"
" beer\n"
"beer\n"
"fir")
subst = "yah"
result = regex.sub(subst, test_str)
if result:
print(result)