re = /(([A-Za-z]+)|((?:[+-])?[0-9.]+)|([&=><\|!]+)|(\S))/m
str = '5--4=sin(2+3-4)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end