#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[!]\[(?P<caption>.*?)\])\((?P<image>.*?)\)"
Local $sString = "This is a regex to detect markdown image links of the form " & @CRLF & _
"" & @CRLF & _
"Here are some markdown links" & @CRLF & _
"- [pandoc-fignos](https://github.com/tomduck/pandoc-fignos): Numbers figures and figure references." & @CRLF & _
"The images section will walk you through how to add and reference images so that the pandoc system can properly number them. For example, this [figure](./ch0_1_images.md#fig:ch0_1_images-1) illustrates a VOD curve for a packaged watergel explosive and this [figure](./ch0_1_images.md#fig:ch0_1_images-2) depicts a circular arc." & @CRLF & _
"## [Equations](./ch0_2_equations.md#sec:ch0_2_equations-1)" & @CRLF & _
"The equations section will discuss how to use equations and reference them properly. See the [internal energy equation](./ch0_2_equations.md#eq:ch0_2_equations-1) or the [detonation pressure](./ch0_2_equations.md#eq:ch0_2_equations-2)" & @CRLF & _
"This string does not contain any links" & @CRLF & _
"" & @CRLF & _
"Here are some image links:" & @CRLF & _
"{#fig:id}" & @CRLF & _
"{#fig:id tag="B.1"}" & @CRLF & _
"{#fig:ch0_1_images-1 width=100%}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")