$re = '/(?<!\d[- \/.])(?<!\d)(3[01]|[12][0-9]|0?[1-9])[- \/.](1[012]|0?[1-9])[- \/.](?:\d{2})?(\d?\d)(?![- \/.]?\d)/';
$str = 'Correct:
01/01/2000
01/Jan/2000
31/01/2000
31/Jan/2000
31.Jan.2000
31-Jan-2000
01/1/2000 x form
01/Jan/2000
01/1/01 x form
01/Jan/01
29/02/2000 x date
29/Feb/2000
28/02/2001
28/Feb/2001
30/04/2000
30/Apr/2000
31/07/2000
31/Jul/2000
31/08/2000
31/Aug/2000
01/12/2000
01/Dec/2000
31-01-8888 ?
02/Jan-1984
1.1.0 x form
10.11.12
all catched as x form
0,0,0
test 31.100.1952
32/03/18
1.2.3
123.2.12
_22.02.18_
22-02-18test
22/02-18
22//02/18
22 02-18
22:02:18
1,2,3
False:
32/01/2000 x form
32/Jan/2000
01/15/2000 x form
29/02/2001 x date
29/Feb/2001
29/02/1900 x date
31/04/2000 x date
31/Apr/2000
31/09/2000 x date
31/Sep/2000
1.2.3-4
1-2-3.4
10.10.10.10
2w4w6
... falls on the date of 10.11.12.
... it.10.11.12 has some type - there should be a whitespace but ....';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);