$re = '/[78]( --[(][)]*[0-9]{10})/';
$str = ' \'84951234567\', \'+74951234567\', \'8-495-1-234-567\',
\' 8 (8122) 56-56-56\', \'8-911-1234567\', \'8 (911) 12 345 67\',
\'8-911 12 345 67\', \'8 (911) - 123 - 45 - 67\', \'+ 7 999 123 4567\',
\'8 ( 999 ) 1234567\', \'8 999 123 4567\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);