const regex = /(?:\p{Extended_Pictographic}[\p{Emoji_Modifier}\p{M}]*(?:\p{Join_Control}\p{Extended_Pictographic}[\p{Emoji_Modifier}\p{M}]*)*|\s|.)\p{M}*/guy;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\p{Extended_Pictographic}[\\p{Emoji_Modifier}\\p{M}]*(?:\\p{Join_Control}\\p{Extended_Pictographic}[\\p{Emoji_Modifier}\\p{M}]*)*|\\s|.)\\p{M}*', 'guy')
const str = `f🗿☺⣿🧀f🌚g👨👩👧👦ll🏳️🌈o͂ȩl^^🔥
👨❤️💋👨अनुच्छेद
s👌뎌쉐👌🏽a
s👩💻f🎉ggZ͑ͫ̓ͪ̂ͫ̽͏̴̙̤̞͉͚̯̞̠͍A̴̵̜̰͔ͫ͗͢L̠ͨͧͩ͘G̴̻͈͍͔̹̑͗̎̅͛́Ǫ̵̹̻̝̳͂̌̌͘!͖̬̰̙̗̿̋ͥͥ̂ͣ̐́́͜͞`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}