re = /((marque)\s?(un)?\s?(but|doublé|triplé)?\s?(à)?\s?(la)?\s?[0-9]?[0-9]?(ème)?)/m
str = 'Hunou marque
Max marque un but à la 4ème
ki marque un doublé à la 45ème minute
Hunou marque triplé'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end