$re = '/^([a-zA-Z0-9._%-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,6})*$/m';
$str = 'name@domain.com
name@
namedomain.com
domain.com
firstname.lastname@domain.com
name@subdomain.domain.com
firstname+lastname@example.com
firstname_lastname@domain.com
firstname-lastname_test@domain.com
firstname$$@domain.com
// You can see the original post at albertcolom.com/blog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);