$re = '/(?i)\b0+([0-9a-f]{1,4})\b|(?:\b|:)((?:0(?::0)+))(?=(:|$))/i';
$str = '2001:0db8:abcd:0012:0000:0000:0000:0001
2001:0db8:abcd:0012:0000:0000:0000:00a2
2001:0db8:abcd:0012:0000:0000:0000:00ff';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;