$re = '/^[+-]?\d+(?:\.\d*(?:[eE][+-]?\d+)?)?$/m';
$str = '10000
1.0E7
1.
1.355
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);