$re = '/\w{2}-\w{3}\d{5}_\d{10}/';
$str = 'pp-gfg76482_8498680983';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);