// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([\s\S].*?)(<.+>)").unwrap();
let string = "<span id=\"3\">
HELLO THERE
<span id=\"5\">
Other stuff
<span id=\"6\">
Other Stuff
<span id=\"7\">
Other sutff";
let substitution = "$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}