#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\S\s]*?)([0-9]+|OVA|Any|Thing|Else|That|Like)"
Local $sString = "Hunter x Hunter OVA 08 = OVA 08" & @CRLF & _
"Hunter x Hunter OVA Greed Island Final 01 = OVA Island 01" & @CRLF & _
"Hunter x Hunter VOA Greed Island Final 01 = OVA Island 01" & @CRLF & _
"Hunter O Hunter VOA Greed Island Final 01 = OVA Island 01" & @CRLF & _
"Hunter x Hunter 02 = 02"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")