const regex = /([\S\s]*?)([0-9]+|OVA|Any|Thing|Else|That|Like)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\S\\s]*?)([0-9]+|OVA|Any|Thing|Else|That|Like)', 'gm')
const str = `Hunter x Hunter OVA 08 = OVA 08
Hunter x Hunter OVA Greed Island Final 01 = OVA Island 01
Hunter x Hunter VOA Greed Island Final 01 = OVA Island 01
Hunter O Hunter VOA Greed Island Final 01 = OVA Island 01
Hunter x Hunter 02 = 02`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}