$re = '/([\S\s]*?)([0-9]+|OVA|Any|Thing|Else|That|Like)/m';
$str = 'Hunter x Hunter OVA 08 = OVA 08
Hunter x Hunter OVA Greed Island Final 01 = OVA Island 01
Hunter x Hunter VOA Greed Island Final 01 = OVA Island 01
Hunter O Hunter VOA Greed Island Final 01 = OVA Island 01
Hunter x Hunter 02 = 02';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);