use strict;
my $str = '<!-- INSTAPAGE: Paths only -->
/
/tax-efficient-guide
/tax-efficient-investing
/tax-efficient-guide-download
/tax-raid-high-earners
/tax-raid-high-earners-download
/tax-efficient-investing-capital-gains
/tax-efficient-investing-capital-gains-download
/pb_iht_guide
/pb-iht-download
/iht-guide
/iht-guide-download
/inheritance-tax
/inheritance-tax-download
/iht-free-isa
/make-isa-iht-free
/iht-free-isa-download
/aim-isa-guide
/aim-isa-guide-download
/eis-factsheet
/EIS-factsheet-download
/seis-factsheet
/seis-factsheet-download
/vct-factsheet
/vct-factsheet-download
/eis-knowledge-intensive
/uktn-download
/free-research-report-octopus-titan
/free-research-report-octopus-titan-download
/investment-ideas
/investment-ideas-download
/isa-iht-free-report
/isa-iht-free-report-download
<!-- WWW SITE -->
';
my $regex = qr/\/tax-efficient-(guide|investing)|\/tax-raid-high-earners/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}