// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/tax-efficient-(guide|investing)|\/tax-raid-high-earners").unwrap();
let string = "<!-- INSTAPAGE: Paths only -->
/
/tax-efficient-guide
/tax-efficient-investing
/tax-efficient-guide-download
/tax-raid-high-earners
/tax-raid-high-earners-download
/tax-efficient-investing-capital-gains
/tax-efficient-investing-capital-gains-download
/pb_iht_guide
/pb-iht-download
/iht-guide
/iht-guide-download
/inheritance-tax
/inheritance-tax-download
/iht-free-isa
/make-isa-iht-free
/iht-free-isa-download
/aim-isa-guide
/aim-isa-guide-download
/eis-factsheet
/EIS-factsheet-download
/seis-factsheet
/seis-factsheet-download
/vct-factsheet
/vct-factsheet-download
/eis-knowledge-intensive
/uktn-download
/free-research-report-octopus-titan
/free-research-report-octopus-titan-download
/investment-ideas
/investment-ideas-download
/isa-iht-free-report
/isa-iht-free-report-download
<!-- WWW SITE -->
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}