$re = '/^.*\([\d.]+\).*$/m';
$str = ' (123.456) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);