#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?si)(.*)<p><a .+href=".+">.+<\/a><\/p>\s(.*)$"
Local $sString = "<h3>СВЕРХПЛОТНОЕ ЗАЩИТНОЕ ПОКРЫТИЕ</h3>" & @CRLF & _
"<p>Тут текст описание и бла-бла-бла</p>" & @CRLF & _
"<p>Состав бла-бла-бла</p>" & @CRLF & _
"<p><a class="download pdf" href="assets/files/techdoc1.pdf" target="_blank"><span>Тех. описание Товара</span></a></p>" & @CRLF & _
"<h3>Область применения</h3>" & @CRLF & _
"<p>Область применения и бла-бла-бла</p>"
Local $sSubst = "$1<!------- Вырезанная ссылка --------->\n$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)