package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)(.*)<p><a .+href=".+">.+<\/a><\/p>\s(.*)$`)
var str = []byte(`<h3>СВЕРХПЛОТНОЕ ЗАЩИТНОЕ ПОКРЫТИЕ</h3>
<p>Тут текст описание и бла-бла-бла</p>
<p>Состав бла-бла-бла</p>
<p><a class="download pdf" href="assets/files/techdoc1.pdf" target="_blank"><span>Тех. описание Товара</span></a></p>
<h3>Область применения</h3>
<p>Область применения и бла-бла-бла</p>`)
var substitution = []byte("$1<!------- Вырезанная ссылка --------->\n$2")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}