$re = '/(?i)\bUsername\h*[:;]\h*\K\S+/mi';
$str = 'Username:dasdsad
username ;dasdsad
username : dasdsad
username; dasdsad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);