#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:([abc])(?!.*\1)){3}$"
Local $sString = "abc" & @CRLF & _
"bac" & @CRLF & _
"cba" & @CRLF & _
"acb" & @CRLF & _
"cab" & @CRLF & _
"" & @CRLF & _
"a" & @CRLF & _
"ab" & @CRLF & _
"ba" & @CRLF & _
"bc" & @CRLF & _
"ca" & @CRLF & _
"c" & @CRLF & _
"aba" & @CRLF & _
"acc" & @CRLF & _
"abb" & @CRLF & _
"cca" & @CRLF & _
"aab" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")