using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^local\(\s*(['""])?\s*([^()]+?)\s*\1?\s*\)$";
string input = @"local('./1.png')";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}