// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w+)=((?:<!\[CDATA\[.*?]]>|[^;])+)").unwrap();
let string = "prop1=value1;prop2=<![CDATA[String test='1234';int i=4;]]>;prop3=value3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}