$re = '/^urn:abc:de:xyz:\d{6,12}\.\d{1,7}(?:\.[\w-]{1,20})+$/m';
$str = 'urn:abc:de:xyz:234567.1890123.abd12
urn:abc:de:xyz:234567.1890123
urn:abc:de:xyz:234567.1890ANC
urn:abc:de:xyz:234567.1890123
urn:abc:de:xyz:234567.1890ACB.123
urn:abc:de:xyz:234567.1890123.ABC123.-_12
urn:abc:de:xyz:234567.1890ABC.ABC123.-_12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);