const regex = /(\\usepackage{(?:tikz|pgfplots)}|\\(?:tikzset|pgfplotsset){(?:[^{}]+|{(?:[^{}]+|{(?:[^{}]+|{[^{}]+})+})+})+}|\\(?:usetikzlibrary|usepgfplotslibrary){[\w\.,]+}|\\definecolor{\w+}{\w+}{[^}]+}|\\colorlet{\w+}{{[^}]+}})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\\usepackage{(?:tikz|pgfplots)}|\\\\(?:tikzset|pgfplotsset){(?:[^{}]+|{(?:[^{}]+|{(?:[^{}]+|{[^{}]+})+})+})+}|\\\\(?:usetikzlibrary|usepgfplotslibrary){[\\w\\.,]+}|\\\\definecolor{\\w+}{\\w+}{[^}]+}|\\\\colorlet{\\w+}{{[^}]+}})', 'gm')
const str = `\\documentclass{article}
\\usepackage{tikz}
\\usetikzlibrary{decorations.markings}
\\tikzset{
->-/.style={
postaction=decorate,
decoration={markings,mark=at position #1 with \\arrow{>}}
}
}
\\begin{document}
\\begin{center}
\\begin{tikzpicture}
\\draw[->-=0.5] (0,0) -- (3,-2);
\\end{tikzpicture}
\\end{center}
\\end{document}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}