# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\\usepackage{(?:tikz|pgfplots)}|\\(?:tikzset|pgfplotsset){(?:[^{}]+|{(?:[^{}]+|{(?:[^{}]+|{[^{}]+})+})+})+}|\\(?:usetikzlibrary|usepgfplotslibrary){[\w\.,]+}|\\definecolor{\w+}{\w+}{[^}]+}|\\colorlet{\w+}{{[^}]+}})"
test_str = ("\\documentclass{article}\n"
"\\usepackage{tikz}\n"
"\\usetikzlibrary{decorations.markings}\n\n"
"\\tikzset{\n"
" ->-/.style={\n"
" postaction=decorate,\n"
" decoration={markings,mark=at position #1 with \\arrow{>}}\n"
" }\n"
"}\n\n"
"\\begin{document}\n"
"\\begin{center}\n"
" \\begin{tikzpicture}\n"
" \\draw[->-=0.5] (0,0) -- (3,-2);\n"
" \\end{tikzpicture}\n"
"\\end{center}\n"
"\\end{document}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.