re = /^(?!(\s*[nN]\/[aA])\s*$).*/m
str = 'n/a
N/A
n/a
N/A
this does not match the regex'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end