#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\s(?:[^'"/\s><]+?)[\s/>])|(?:\S+(?:\s*=\s*(?:(?:(['"])[\s\S]*?\1|([^\s>]+))|(?:[^'"\s>]+))))"
Local $sString = " <div" & @CRLF & _
" blah lorem" & @CRLF & _
" foo-bar" & @CRLF & _
" multi-line="" & @CRLF & _
" foo" & @CRLF & _
" bar" & @CRLF & _
" "" & @CRLF & _
" bar=" asdf"" & @CRLF & _
" bar= zxcv " & @CRLF & _
" foo=asdf" & @CRLF & _
" aa=df-bar=()" & @CRLF & _
" a-b=df-b"ar=()" & @CRLF & _
" ac=df"-bar=()" & @CRLF & _
" ad=df-bar=()" & @CRLF & _
" ></div>" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")