$re = '/A(?:(?![A-Z]{2}).)*?(\d+)/m';
$str = 'A bcd 1 should match and capture 1
Abcd1 should match and capture 1
A bcd
A BCd 1
A bcd 1 EF
must start with an A
followed by any count of anything unless it\'s two consecutive upper case letter
followed by a number (which should be captured)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);