# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/s\d+x\d+\\//\/s720x720\//;t' <<< "cd.com/vp/3070d0210e464e/5AEFB3ED/t51.2885/s150x150/24845474_1790806444289980_66798452736_n.jpg
"