#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\/s\d+x\d+\/"
Local $sString = "cd.com/vp/3070d0210e464e/5AEFB3ED/t51.2885/s150x150/24845474_1790806444289980_66798452736_n.jpg" & @CRLF & _
""
Local $sSubst = "/s720x720/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)