using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/s\d+x\d+\/";
string substitution = @"/s720x720/";
string input = @"cd.com/vp/3070d0210e464e/5AEFB3ED/t51.2885/s150x150/24845474_1790806444289980_66798452736_n.jpg
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}