package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/s\d+x\d+\/`)
var str = []byte(`cd.com/vp/3070d0210e464e/5AEFB3ED/t51.2885/s150x150/24845474_1790806444289980_66798452736_n.jpg
`)
var substitution = []byte("/s720x720/")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}