// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/s\d+x\d+\/").unwrap();
let string = "cd.com/vp/3070d0210e464e/5AEFB3ED/t51.2885/s150x150/24845474_1790806444289980_66798452736_n.jpg
";
let substitution = "/s720x720/";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}