#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\burl\((?<url>[^()]+)\)"
Local $sString = "@font-face {" & @CRLF & _
" font-family: "JetBrains Mono";" & @CRLF & _
" font-style: normal;" & @CRLF & _
" font-weight: 400;" & @CRLF & _
" src: local("JetBrainsMono-Regular")," & @CRLF & _
" url(JetBrainsMono/JetBrainsMono-Regular.ttf) format("truetype");" & @CRLF & _
"}" & @CRLF & _
"@font-face {" & @CRLF & _
" font-family: "JetBrains Mono";" & @CRLF & _
" font-style: normal;" & @CRLF & _
" font-weight: 700;" & @CRLF & _
" src: local("JetBrainsMono-Bold")," & @CRLF & _
" url(JetBrainsMono/JetBrainsMono-Bold.ttf) format("truetype");" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")