const regex = /(?<=Total\r?\n\r?\n?)(.+)(?=\s+\d+\s+\d+\s+[A-z]{3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Total\\r?\\n\\r?\\n?)(.+)(?=\\s+\\d+\\s+\\d+\\s+[A-z]{3})', 'gm')
const str = `Item Description Quantity Price Per Total
Various paper supplies 1 269033 USD 269033 USD`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}