use strict;
my $str = '{field: "platformID",
displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID",
quickSearch: true,
search: {operator: [\'eq\', \'ne\', \'cn\', \'gt\', \'lt\']},
sortFunc: \'number\'
},
{field: "platformName",
displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID",
quickSearch: true,
cellTemplate: \'<a href="#/clemove/clemoveDetaiPlatform/{{row.platformID}}" translate="{{row.platformID}}"></a>\',
search: {operator: [\'eq\', \'cn\']},
},
{field: "platformOwnerTEF",
displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID",
quickSearch: true,
search: {operator: [\'eq\', \'cn\']},
sortFunc: \'number\'
},
{field: "platformOwnerZTE",
displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID",
quickSearch: true,
search: {operator: [\'eq\', \'cn\']},
sortFunc: \'number\'
},
{field: "platformVendor",
displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID",
quickSearch: true,
search: {operator: [\'eq\', \'cn\']},
sortFunc: \'number\'
},
{field: "platformE2E",
displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID",
quickSearch: true,
search: {operator: [\'eq\', \'cn\']},
},
{field: "platformInternalDependency",
displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID",
quickSearch: true,
search: {operator: [\'eq\', \'cn\']},
},
{field: "platformServiceDependency",
displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID",
quickSearch: true,
search: {operator: [\'eq\', \'cn\']},
},
{field: "platformPreferedMoveDate",
displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID",
quickSearch: true,
search: {operator: [\'eq\', \'cn\']},
},
{field: "platformUnpreferedMoveDate",
displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID",
quickSearch: true,
search: {operator: [\'eq\', \'cn\']},
},
{field: "platformAdditionalTool",
displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID",
quickSearch: true,
search: {operator: [\'eq\', \'cn\']},
},
{field: "platformVM",
displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID",
quickSearch: true,
search: {operator: [\'eq\', \'cn\']},
},
{field: "platformCommunicationMatrix",
displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID",
quickSearch: true,
search: {operator: [\'eq\', \'cn\']},
},
{field: "stateName",
displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID",
quickSearch: true,
search: {operator: [\'eq\', \'cn\']},
cellFilter: \'translate\',
},
{field: "modeName",
displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID",
quickSearch: true,
search: {operator: [\'eq\', \'cn\']},
},
{field: "relocationgroupName",
displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID",
quickSearch: true,
search: {operator: [\'eq\', \'cn\']},
},';
my $regex = qr/field: "(.*?)"/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}