package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?(?:cot|lan)\s*`)
var str = `The cot that I bought yesterday is the cheapest one`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}