using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<one>M\/S\s(\w+?\s)+(?<two>(U22334)))";
string input = @"M/S ALPHA DAILY LIVING PRODUCTS INDIA PRIVATE LIMITED U22334";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}