// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?<one>M\/S\s(\w+?\s)+(?<two>(U22334)))").unwrap();
let string = "M/S ALPHA DAILY LIVING PRODUCTS INDIA PRIVATE LIMITED U22334";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}