$re = '/(?<=\d)_\d(*SKIP)(*FAIL)|_/m';
$str = '_this_is_a_2_2_replacement_';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;