re = /(\w+) (?=pen\s)/m
str = 'black pen
black pencil
red pen
red crayon
purple crayon
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end