import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<localPart>(?<dotString>[0-9a-z!#$%&'*+-\\/=?^_`\\{|\\}~\\u{80}-\\u\\{10FFFF\\}]+(\\.[0-9a-z!#$%&'*+-\\/=?^_`\\{|\\}~\\u{80}-\\u\\{10FFFF\\}]+)*)|(?<quotedString>\"([\\x20-\\x21\\x23-\\x5B\\x5D-\\x7E\\u{80}-\\u\\{10FFFF\\}]|\\\\[\\x20-\\x7E])*\"))(?<!.{64,})@(?<domainOrAddressLiteral>(?<addressLiteral>\\[((?<IPv4>\\d{1,3}(\\.\\d{1,3}){3})|(?<IPv6Full>IPv6:[0-9a-f]{1,4}(:[0-9a-f]{1,4}){7})|(?<IPv6Comp>IPv6:([0-9a-f]{1,4}(:[0-9a-f]{1,4}){0,5})?::([0-9a-f]{1,4}(:[0-9a-f]{1,4}){0,5})?)|(?<IPv6v4Full>IPv6:[0-9a-f]{1,4}(:[0-9a-f]{1,4}){5}:\\d{1,3}(\\.\\d{1,3}){3})|(?<IPv6v4Comp>IPv6:([0-9a-f]{1,4}(:[0-9a-f]{1,4}){0,3})?::([0-9a-f]{1,4}(:[0-9a-f]{1,4}){0,3}:)?\\d{1,3}(\\.\\d{1,3}){3})|(?<generalAddressLiteral>[a-z0-9-]*[[a-z0-9]:[\\x21-\\x5A\\x5E-\\x7E]+))\\])|(?<Domain>(?!.{64,})(([0-9a-z\\u{80}-\\u\\{10FFFF\\}]([0-9a-z-\\u{80}-\\u\\{10FFFF\\}]*[0-9a-z\\u{80}-\\u\\{10FFFF\\}])?))(\\.([0-9a-z\\u{80}-\\u\\{10FFFF\\}]([0-9a-z-\\u{80}-\\u\\{10FFFF\\}]*[0-9a-z\\u{80}-\\u\\{10FFFF\\}])?))*))$";
final String string = "postmaster@[123.123.32.245]";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}