const regex = /(?<=\\Desktop|Downloads\\)(?<EXE_RAN>.*\.exe)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\\\Desktop|Downloads\\\\)(?<EXE_RAN>.*\\.exe)', 'gm')
const str = `C:\\users\\user1\\Downloads\\blah.exe
C:\\Users\\user234\\Downloads\\sqldeveloper-17.4.0.355.2349-x64\\sqldeveloper\\sqldeveloper\\bin\\sqldeveloper64W.exe
C:\\Users\\user9823\\AppData\\Local\\iManage\\Installer\\Updates\\iManage Work Desktop for Windows x86.exe
C:\\Users\\johnsmith\\Desktop\\dataloader-44.0.0.exe
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}