$re = '/\d/m';
$str = 'Le monde - Vendredi 22 Avril.pdf
Le Monde du 22 Avril 2022 Pdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);